Introduction to iMovie
(iMovie 10.0.5)

Digital Media Commons
129 Herring Hall

http://dmc.rice.edu
dmc-info@rice.edu
713-348-3635
Course outline:

Part I - Introduction
- What is iMovie ......................................................... 2
- iMovie interface ......................................................... 3-4
- iMovie file structure and back up ................................ 5

Part II – Input
- Import from file-based camera .................................. 5-6
- Import from tape-based camera .................................. 6
- Import from computer .................................................. 6

Part III – Basic editing
- Start a project ......................................................... 7
- Rate clips ................................................................. 7
- Rough cut ............................................................... 7-8
- Edit video ............................................................... 8-9
- Insert images and adjust the Ken Burns Effect .............. 10
- Movie properties ..................................................... 11
- Advanced adjustments .............................................. 11-12
- Use green-screen effects .......................................... 12-13
- Edit audio ............................................................. 13
- Record a voiceover ................................................... 14
- Add transition and Titles ........................................... 14-15

Part IV – Share
- Share to iMovie theater .............................................. 15
- Export a QuickTime file ............................................. 16
- Publish to YouTube .................................................. 17

Reference ........................................................................ 17
Part I – Introduction

1. What is iMovie

iMovie is a Mac based video editing software, aimed at entry-level and for the amateur consumer. It provides all the basic features in a clean, easy interface. The latest version of iMovie is 10.0.5 as of 9/18/2014. This version of iMovie is a complete redesign with more options to share a movie, more movie and trailer theme options from iMovie for iOS, easier to make picture-in-pictures, cutaways, side-by-sides etc., more realistic green-screen effects and easier refinements.

2. iMovie workspace

iMovie workspace is composed of one toolbar and four main windows, which are Library pane, Browser pane, Viewer pane, and Project pane.

- The left side of the iMovie window contains the Libraries pane. The top portion of this pane is filled with links to your photos, projects, and movie events. The bottom portion of this page contains transition and text generators where you can access to different transition and title effects. It also has the links to different backgrounds, map routes, your iTune library and sound effects.

- The Browser pane displays the content in your library pane depending on which library is currently being selected. It may display all your source medias for your preview if you select a
certain library; it may display a list of projects you have created, or photos from your iPhoto library, audio files from iTune library, or different transitions or titles.

• The large **Project pane** at the bottom of the iMovie window is for assembling your movie. By default the Project pane displays clips in a traditional timeline view. You may select clips or portions of a clip from Browser pane and add to your project. You can also add special effects such as transitions, titles, or music to your project in this pane.

• The **Viewer pane** appears at the top-right of the iMovie window. When you select a media item in the Browser pane, information about the item will appear in the Viewer. It either displays a certain clip from browser window or a project from the project pane depending on which content is currently selected. The Viewer pane is also the place where you can edit media by using the tools provided in the toolbar (Enhance or Adjust).

• The **Toolbar**: iMovie does its best to keep you from turning to menus for common commands by placing those commands in the toolbar at the top of the window. You can import media, create a new movie or trailer, share your work with others in different ways.

The toolbar provides two different views: **Library view** and **Theater view**. iMovie default view is Library, in which you can view your media assets and work on your project. The Theater is iMovie’s version of Photo Stream. When you add your finished movies to iMovie Theater, the movies are shared with any compatible Mac or iOS device that has the latest version if iMovie installed and is linked to your Apple ID.

**Enhance** tool will apply various corrections to the clip – increasing its contrast or saturation for example. iMovie applies these enhancements for you. If you don’t like the enhancement, you click on Enhance again to undo.


You can close Project window, resize Browser and Viewer window, hide Library pane by clicking on located on the upper left corner. To revert back to original layout, go to top menu > **Window > Revert To Original Layout**.

Last updated on 9/25/2014
3. iMovie File Structure and Back-up

All your movie projects should reside in an iMovie Event that is within an iMovie Library. By default, your iMovie Library is located on your hard drive > HOME > Movies > iMovie Library.

If you start an iMovie project at the DMC, it is required to save your library to SAVEWORKHERE drive. It is the same way when you save your iMovie library to an external drive. To do so:

1) Connect your external drive to the computer
2) Open iMovie
3) Go to File>Open Library>New...to create a new library
4) Make sure to select your external drive on the left navigation bar if it is connected or SAVEWORKHERE drive on DMC computers.
5) You should see an iMovie library created in your external drive or DMC SAVEWORKHERE drive.

NOTE: If you don’t remember where you saved your library, event, or project, you can simply click on the clip in the browser pane, go to top menu, click on File > Reveal in Finder to locate all your media, or media library. Then you can drag your library to your drive to back up.

There is no save button as iMovie automatically saves all your clips, project files and any edits.

Part II - Input

1. Capture footage from MiniDV tape

We recommend you using DMC MiniDV deck on station 4 or 5 to capture footage from
MiniDV tape.
1) Insert MiniDV tape into the deck.
2) Open iMovie and create new library as shown in above iMovie back-up section.
3) Click Import from the toolbar.
4) Create an event under your library, as the captured footage has to reside in a certain event. To create an event, click Import to > New Event...
5) Select the playback device on the left in the Import window. Then control your tape playback to cue up your tape.
6) Play the tape and click Import button to capture the footage.
7) Click Stop Import if it is done.

2. Transfer footage from memory card based camera

1) Connect video camera to computer via USB cable (leave the memory card in camera).
2) Turn on Canon VIXIA HF M500 and press the (camera/play) button. The camera should now appear as a storage device on the desktop.
3) Create a new library as shown in above iMovie back-up section.
4) iMovie should automatically detect the camera connection and bring up the capture window, if not, click on from the toolbar and choose CANON under CAMERAS on the left.
5) Create an event under your library, as transferred files have to reside in a certain event. To create an event, click Import to > New Event...
6) The transfer window should display all the clips on your memory card. To import all clips, click on Import All. To import individual clips, click on Import Selected.
7) Your files should be placed in the event you created after import is complete. You can now begin editing.

3. Import files from computer

To import media from computer or external drive, simply go to File > Import Media..., select your file and click Import Selected.

iMovie, as part of the iLife suite, is integrated with your iTunes and iPhoto libraries. To use an audio or image file from your iPhoto or i Tune library, click on in the Library pane, preview and select in the Browser pane, then drag to add it to your project in the Project pane.
Part III – Basic Editing

iMovie, as compared to other amateur market video editors, is easy to use and feature-heavy. iMovie employs a simple visual editing interface. Clips can be dragged to the project window, where they can be cut, combined or edited with effects.

1. Start a Project

The first step to editing video in iMovie is to create a project file. A Project file is an iMovie file that stores references to all of your media clips and information about how you arranged and edited the clips. Everything used in your project will be accessible and organized under this name.

*Note:* Since a project file resides in an event that is in a Library, be sure to create your iMovie library under DMC SAVEWORKHERE drive or your own external drive first, and create an event *before* you start a project. To create a new event under a certain library, go to File > New Event.

With appropriate Library and Event being selected in the Library pane, click on the toolbar to create a movie. There are many themes to choose from. Click on play button to preview a theme. To use a theme, select and choose Create. To have more control over the layout and edit, No Theme is recommended. Select No Theme and you should see an empty space appearing in the Project pane.

2. Rate clips

Now you’re ready to bring clips from your events to project, but before you do this, you would need to skim through your clips in the Browser and decide which portions will be brought into the project. You may notice that some footages are good shots, whereas others you probably will never use. As you preview clips to use for your movie, you can rate them by right-clicking your mouse and choose either Favorite or Reject.

After rating, if you want to view all favorite shoots in the Browser, you can click on Hide Rejected next to the search field in the Browser pane, then choose Favorites from the drop down menu. The Browser pane should now display all your favorite shoots.

3. Rough Cut: A rough cut is a series of clips arranged in the general sequence that you want. It will provide a basic layout for your sequence and give you a sense of where you want to apply edits, add transitions, and create effects. Use the following steps to create a rough cut. Don’t worry about precise editing until later.

   1) Select clips

To browse through the footage in the Browser pane, select an event, move your mouse over the filmstrips. This is called skimming.

To select a section of film, click on the first moment you want to show in your movie and drag
the yellow box that appears all the way to the last second of movie to be used. This is just like highlighting chunk of text in a Word document. You can select from right to left or left to right.

Note that you can adjust clip thumbnail appearance in the Browser pane by clicking on the upper right corner of Browser window. Use slider to adjust clip size, zoom in clips up to ½ sec for more precise selection or zoom out to a single clip view.

2) Add clips to your project:
- After you highlighted a section, you can drag it to the desired point on the Project pane.
- To add clips to the very end, click button appeared on the selected filmstrip, or use keyboard shortcut “E”.
- To insert a clip at the playhead location, use keyboard shortcut “W”.
- To rearrange the clips in your project, simply drag them to the desired location and release the mouse button.
- Press backslash key “ \ ” to play the movie from the beginning.

3. Edit video
Once you have your rough cut, you’re ready to begin editing your sequence.

Use zoom slider located on the upper right corner of Project pane to zoom in for precise editing. You can zoom up to ½ second. You can also adjust thumbnail appearance or turn on/off audio waveforms.

1) Trim a clip: If you moved a little too much or less footage into the Project timeline, you may trim it down or bring it back.

- View the clip you wish to edit in the viewer, make selection by clicking and holding your mouse for a sec until you see this yellow box appear . Adjust the size of the box to cover the area you want to keep, go to Modify>Trim Selection. The unwanted frames are removed and only highlighted portion remains.
- To make your clip longer or shorter, drag the edge of the clip left or right to adjust.
- To trim a clip from beginning to a certain frame, park your playhead at the frame you want your clip to begin, right click your mouse, choose Trim to Playhead from the dropdown menu.
- If you need more precise control over your trimming, you need to use Clip Trimmer. To get to the Clip Trimmer, right click on the clip, choose Show Clip Trimmer from the dropdown menu or use keyboard shortcut ‘command\'.

Last updated on 9/25/2014
• The clip trimmer displays the entire master clip, the part that is appearing in the movie is highlighted between two white bars.
• You can now drag either side of the selection box to add/remove single frame at a time from beginning or end of your clip.
• You can also click and drag the entire clip to change the both end at the same time while keeping the overall length of the clip same. This is known as ‘slip editing’, which is especially useful if you have already set up music, transitions or narration to be timed to fit the video.
• To close the clip trimmer, just double click on the clip holder.

2) **Precision Editor:** The precision editor opens up below the project editor, and shows you exactly where your clips overlap, letting you make minute adjustments between clips. To open up Precision Editor, click on the edit point between two clips. The unused footage from master clips will be displayed. Drag left or right to adjust where the first clip ends and the second clip starts. While using Precision Editor to adjust between clips, you can also do a slip editing to shift the content.

![Click to open Precision Editor](image)

3) **Split:** Splitting involves making a clip into two or more pieces. It is helpful if you wish to move parts of clips to other positions in your sequence, add effects to a piece of a clip, or superimpose additional clips.

Park your playhead at the frame you want to split, right click your mouse and choose Split Clip from the drop-down menu, or press keyboard shortcut ‘command B’.

4) **Crop & Rotate:** You can crop video clips much like you crop photographs and images

• Select the clip you want to crop, click on Adjust in the toolbar on top of viewer window. The crop tool is the third tool.
• There are three styles under crop tool: Fit, Crop to Fill, Ken Burns. Select Crop to Fill. Adjust the size of outline, if satisfied, click on to confirm.
• Be sure do not zoom in too much, so that your video does not look pixelated.
• To rotate footage, click on on the upper right of viewer window to rotate left or right.
4. Insert images and adjust the Ken Burn effect

1) Creating still frames:

• Position the playhead at the frame of your desired image.
• Right click your mouse and choose Add Freeze Frame. The image is added to the end of your selected clip as a four-second clip.
• You can then select freeze frame to move to your desired location.

2) Inserting images: Movies created in iMovie 10.0.5 are wide screen with dimension of 1920x1080. Pictures in 1920px x 1080px are most flexible in iMovie when you apply Fit, Crop, or Ken Burn effect. Be sure to resize your picture to 1920x1080 in image editing software before bring them into iMovie.

• Access your image in iPhoto by clicking on in the Library pane.
• Drag and drop the image to the project window where you want your image to be.
• If you drop the image on top of a clip, you are adding the image as a cutaway. You should see a Video Overlay Setting button appeared as the first tool under the Adjust.
• You can choose different overlay setting, such as Side by Side, or Picture in Picture, you can also adjust opacity level, etc. Click on to confirm the settings.

Ken Burns Effect: After inserting a still image, you can change how it behaves within your project. The Ken Burns Effect lets you apply camera moves like zooms and pans to otherwise static shots. It is the default setting for all imported photos.

Ken Burns effect is the third style under Cropping tool. After you click on Ken Burns, you should see start and end boxes appearing on the image. The start box frames the portion of the image you want to see when the frame first appears on screen, and the end box is the portion you want to see by the end of the clip. You just position and size both boxes, and iMovie creates the zoom effect between those two points.
5. **Movie Properties**: iMovie has a number of settings you can customize for your movie. These settings determine how your movie is assembled, the theme used by the movie, and so on.

1) With your movie open in the timeline, choose Window > Movie Properties, Information about your movie appears above the viewer
2) Click the Setting button. Editable movie settings appear above the viewer.

3) Do any of the following:

   - To choose how photos are treated when added to your movie: Choose **Fit, Crop, or Zoom** from the “Photos placement” pop-up menu.
   - To choose a theme for your project: Click the Theme button, choose a theme, and then click Change.
   - To remove the theme from your project: Click the Theme button, choose No Theme, and then click Change.
   - To have iMovie automatically add titles and transitions to your movie: Select the “Automatic content” checkbox.
   - To set the default duration of clips added to your movie: Drag the Clips slider.
   - To set the default duration of transitions added to your movie: Drag the Transitions slider.
   - To automatically trim background music to fit the length of your movie: Select the “Trim background music” checkbox.

6. **Advanced Adjustment of Clips**: iMovie put together a lot of cool adjustments in a single Adjust toolbar, which you access by clicking the **Adjust** button at the top of Viewer window.


- **Color Balance** control lets you easily change the tone of your clip. The **Auto** option prompts iMovie to analyze the current frame and change the colorcast of the clip based on its calculations of what looks best. With **Match Color**, the viewer presents a split view, one portion displays the current frame, and the other shows a frame with a look that you’d like to mimic in the
current frame. The **White Balance** option lets you automatically choose a white balance based on a neutral color. When you choose this option, the eyedropper tool appears, click a neutral color within the frame to change the balance. The **Skin Tone Balance** option works similarly. Click the eyedropper on the skin of someone in the frame, the color shifts to balance against that tone.

- **Color Correction**: You adjust color correction through the use of three sliders. The first is for tweaking brightness and contrast; the second and third sliders are more straightforward. One is for adjusting the clip’s saturation; the other is for changing the clip’s color temperature.

- Refer page 9 and 10 in this handout for instruction on how to use **Crop** tool.

- **Stabilization**: Two controls appear when you select the Stabilization control-Stabilize Shaky Video and Reduce Rolling Shutter Distortion. Check the box to apply Stabilization and adjust the settings as necessary.

- **Volume**: Here you find controls for adjusting the sound of the selected clips.

  The first control is **Auto**, which normalizes the audio so that the loudest sounds in the audio track are increased to the point just below distortion and quieter audio is brought up proportionally. Next is a Mute button for entirely muting selected clip’ audio. Then **Volume Slider** is to increase or decrease the audio of the selected clips. **Lower Volume of Other Clips** slider known as ‘duking’, is to ensure that the audio within our clips is louder than any other audio track that is playing at the same time—a background music track for example.

- **Noise Reduction and Equalizer**: First Reduce background noise slider is to adjust how much nose to let through. Equalizer presets emphasize or deemphasize certain audio frequencies – to bring up the bass or treble, for example.

- **Speed**: Click Speed to see fast and slow motion options. You can choose preset percentage or define various speeds by choosing **Custom**.

- **Video and audio effects**: **Video Effects** offers 20 effects such as Black & White, Flipped, etc. Hover your pointer over an effect to see it applied to a sample of your video in the Viewer. Click an effect to apply it. The **Audio Effect** menu allows you to add sound effects to your clip’s audio track. The reverb effects could be useful. The others are mostly for goofing around.

7. **Use green-screen effects**: You can record video in front of a green or blue backdrop, and then “cut out” the subject and superimpose it into another video clip. This is called a “green-screen” or “blue-screen” effect. You can also drag the green-screen or blue-screen clip over a solid-color or animated background clip.

   1) In the timeline, select a clip or range that you shot against a green or blue backdrop, and drag it **above** a clip in your project. When you see the green Add icon (+), release the mouse button.
2) Click the Adjust button in the toolbar. The adjustments bar appears above the viewer. If the cutaway controls aren’t shown, click the Video Overlay Settings button. Choose Green/Blue Screen from the pop-up menu on the left. The Green/Blue Screen controls appear.

3) In the viewer, the clip shot against the green or blue backdrop has the green or blue removed, and the clip below shows through the areas that were green or blue, creating a composite image.

4) To apply the changes, click the Apply button to the right of the cutaway controls.

5) To adjust a green-screen or blue-screen effect, do any of the following:

   a. To adjust the softness of the edges of the superimposed clip: Drag the Softness slider.

   b. To isolate areas of the green-screen or blue-screen clip: Click the Crop button, and then drag the corners of the frame to isolate the subject in the foreground clip.

   c. To clean up areas of the green-screen or blue-screen clip: Click the Clean-up button, and then drag across stray parts of the green-screen or blue-screen clip that should not be showing. Each time you drag, iMovie uses the new selection to determine what should be cleaned up.

8. Edit your audio (please refer above Volume, Noise Reduction and Equalizer, and Audio Effect for more controls under Adjust toolbar):

   • To move an audio file, simply hold mouse and move audio file to your desired location.
   • To trim the beginning or the end off of an audio file, simply click and drag left or right.
   • To detach audio from video of a clip, right click your mouse and choose Detach Audio from drop down menu, the audio track is now seperated, you can then select and delete audio file or make adjustment as needed.
   • To fade in and out of the beginning and end of an audio clip, click and drag the fade controls in the form of small dots that appear on both ends of audio level line.
   • To adjust audio within a single clip, hold the Option key and click points onto the audio-adjustment line. Drag these points up or down to increase or decrease that portion of the audio respectively.
9. **Record a voiceover:** You can record your own narration to add to your movie.

1) Position the playhead where you want to start recording in the timeline, and choose **Window > Record Voiceover**, or use keyboard shortcut ‘V’. The voiceover recording controls appear below the viewer.

2) To adjust the recording settings, do any of the following:
   a. To change the input device: Click the Voiceover Options button, and choose an option from the Input Source pop-up menu.
   b. To adjust the input level of the microphone, drag the Volume slider right to increase the volume of what is being recorded, or left to decrease it.
   c. You can monitor the audio levels by using the built-in audiometer on the Record button. You should set the volume so that the audio meter in the microphone (the Record button) stays green, even when your voice is at its loudest.
   d. To mute sound from other clips while recording: Click the Voiceover Options button, and select the Mute Project checkbox.

3) To start recording, click the Record button, iMovie will count down from 3 to 1.

4) To stop recording, click the Record button again (or press the Space bar).
   a. The recorded audio appears as a new clip in the timeline, above the background music. The voiceover clip is attached to the clip that was below the playhead when the recording was started.
   b. The track is named VO-number: movie name, where number is the number of the voiceover you’re recording and movie name is the name of your movie.

5) Click the close button to dismiss the voiceover recording controls.

10. **Add Transition:**

Transition Effects are used to seamlessly link clips together. They are one of the key components of professional video editing. You can use transitions to create artistic effects, like a ripple dissolve to indicate, “It was all a dream...”, or a fade in/fade out to signify the passage of time.

1) Select **Transitions** from Content Library.

2) Select your transition style from the Browser pane and drag and drop in between clips in Project window.

3) To change the duration or a type of transition, double click on the transition and change the duration as needed.
**11. Add title:** iMovie, like many editors, allows you to add text to your films. Text can be added over video or over black and there are a number of different text effects which are available, ranging from music video style to scrolling titles. Some text effects are more artful, such as falling letters or spinning text.

- Click on **Titles** from left Library pane. Preview and choose a **Title** from the Browser pane.
- Click and drag the title onto the Project timeline. If you want the title to stand alone, position your mouse before the appropriate clip before you release the clip.
- If you want the Title to overlay a clip, drag and drop the title on top of a clip.
- To change the duration of a Title, simply drag the edge of a Title left or right.
- To preview the title, press place bar once.
- To change the text, select the title from your timeline and it will appear in the Viewer window. Double click on the text in the Viewer window. You can use the text editor tool appeared on the top of Viewer window to change the font, color, size, etc.

![Text editor tool](image)

- To move a title to different location, click, hold and drag to your desired location.
- To delete a Title, simply click and select and hit Delete key.

**Part IV: Share**

iMovie has a range of export options once a project is completed and ready to be shared. iMovie videos can be exported as simple video files of various sizes (and levels of compression) to the local computer or to the internet or email.

The new version of iMovie allows you to export to iMovie theater as well.

**1. Share to iMovie Theater:** iMovie Theater is built to work with iCloud. If you have an iCloud account, movies you send to the Theater automatically appear on all your other devices, so you can easily watch your movies on your other computers, your iOS devices, and your Apple TV. iCloud keeps your movies private—they are tied to your iCloud account and cannot be viewed by others.

When you add a movie, trailer, or clip to the Theater, iMovie creates versions of your movie tailored for local playback, playback on an iOS device, and streaming. An activity indicator **○** appears on the right side of the toolbar while these other versions are being created. Click the activity indicator to see details. You can continue to work in iMovie, or quit without affecting the share operation. The indicator disappears when the operation has finished.

To share to iMovie Theater, select a movie or your project in the browser, click the Share button in the toolbar and click Theater. The item you selected is sent to iMovie theater. To view your movie, click the Theater button in the toolbar.
2. **Export a mp4 file**: You can export your movie as a mp4 file so that you can play it on any computers. This is also where you’ll get the absolute highest quality final file out of all the other sharing options

1) Select a movie or a project in Browser pane.
2) Click the Share button in the toolbar, and then click File.
3) In the dialog that appears, do any of the following:
   a. To set the title of the shared movie: Click the name at the top, and type a new name.
   b. To set the description of the shared movie: Click in the Description field, and type new text.
   c. To set tags for the shared movie: Click in the Tags field, and type tag names separated by commas.
   d. To set the size of the shared movie: Choose an option from the Size pop-up menu. HD option is recommended for better quality.
   e. To add your movie to the Theater: Select the Add to Theater checkbox.
4) Click Next.
5) In the dialog that appears, type a name in the Save As field, or leave the default name, which is the name of the movie or clip.
6) Navigate to the location where you want to save the file, and click Save.

An activity indicator appears on the right side of the toolbar. Click the activity indicator to see details. The indicator disappears when the operation has finished.

After the share process is complete, the movie opens in QuickTime Player. A “Share Successful” notification also appears.

3. **Publish to YouTube**: You can publish your movie to a number of popular sharing websites, including YouTube, Facebook, Vimeo, and CNN report.

1) Select a movie or a clip in Browser pane.
2) Click the Share button in the toolbar, and then click YouTube.
3) In the dialog that appears, do any of the following:
   a. To set the title of the shared movie: Click the name at the top, and type a new name.
   b. To set the description of the shared movie: Click in the Description field, and type new text.
   c. To set tags for the shared movie: Click in the Tags field, and type tag names separated by commas.
   d. To set the size of the shared movie: Choose an option from the Size pop-up menu. HD setting is highly recommended for better video quality.
   e. To set a YouTube video category for the shared movie: Choose an option from the Category pop-up menu.
   f. To set a YouTube privacy setting for the shared movie, click on Privacy.
   g. To add your movie to the Theater: Select the Add to Theater checkbox.
4) To provide your YouTube account information, do one of the following:
To sign in to your YouTube account: Click the button in the lower-left corner of the dialog and enter your account name and password. If you want iMovie to remember your account information so that you don’t have to enter it again, select “Remember this password in my keychain.” Then click OK.

To finish signing in, follow the onscreen instructions to verify your identity and enable your device, and click Done.

Tip: The name of the account you used last is displayed on the button in the bottom-left corner of the dialog.

5) Click Next and follow the onscreen instructions.

An activity indicator appears on the right side of the toolbar. Click the activity indicator to see details. The indicator disappears when the operation has finished.

After the share process is complete, click Visit in the “Share Successful’ notification to view your movie on YouTube.

Reference:

- iMovie 10.0.2 Essential Training. [www.lynda.com](http://www.lynda.com)