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Tips for Using Excel Productively 
 

Navigation 
 
Freeze Panes 
To keep headings visible while scrolling. Go to menu: 
View > Freeze Panes > Freeze Top Row (to lock first 
row) or position active cell where you wish the lock to 
occur and then select View > Freeze Panes > Freeze 
Panes (applies above and to the left of current cell). 
 
Keyboard Shortcuts 

Arrow keys Move one cell left, right, up or 
down 

Ctrl + Arrow keys Move to the edge of data range in 
worksheet 

Ctrl + End Move to the last cell on a 
worksheet; the lowest used row of 
the rightmost used column 

Ctrl + Home Move to beginning of a 
worksheet. Home move to first 
cell in row. 

Ctrl + Shift + End Extend the selection of cells to 
the last used cell on the worksheet 
(lower-right corner). 

Ctrl + Spacebar Select entire column 
Shift + Spacebar Select entire row 
Shift + Ctrl + F8 Select Multiple Areas 
Ctrl + A Selects the entire data range in 

worksheet 
Ctrl + PgUp 
/PgDn 

Move between sheets in a single 
workbook 

Esc Cancel current action 
F2 Edit selected cell 
F4 Cycle through all combinations of 

absolute and relative references in 
a formula for a cell reference or 
range. 

F5 Go to a specific cell. For 
example, C6. 

F7 Spell check selected text or 
document. 

Ribbon keyboard 
shortcuts 

Press and hold ALT key to show 
small letter by each tab in ribbon, 
then press letter or number to 
open specific tab or menu 

 
For more, see Excel keyboard shortcuts and function keys 
for Windows. https://support.office.com/en-
us/article/Excel-keyboard-shortcuts-and-function-keys-
for-Windows-1798d9d5-842a-42b8-9c99-9b7213f0040f 
(http://tinyurl.com/h6dwkla).  

 
 
View/Zoom Slider 

  
Located at bottom right of window 

_________ 

Status Bar Quick Calculations 
Use status bar (located at bottom right of workbook) to 
display key metrics about the range of data selected. 
Options: sum, min, max, average.  
 
Color Code Sheet Tab 
1) Right click on the tab of the worksheet you want to re-
color.  
2) Select Tab Color from popup menu;  
3) Click on a color to select it;  
4) Click on More Colors at the bottom of the color palette 
to open the custom color palette. Also, accessible from 
the Home > Cells > Format button.  
 
Auto Fill  
Select cell with content to copy/paste. 
Fill handle appears as a small solid square in the bottom-
right corner of the selected cell(s). 

 
Hover mouse over Fill Handle till turns to a black cross. 
Then Double Click to copy values down adjacent cells. 
 
Go to feature  
Use the Go to feature (Ctrl + G) to find things in big 
ranges of data, for example finding blank cells that are 
missing data, which you need to fill in. Or familiarizing 
yourself with a worksheet, such as highlighting cells 
containing formulas. 
 

1) Highlight your range. 
2) Go to menu: Edit > Find > Go To… 
3) Click Special. 
4) Then select Blanks, Formulas, etc. 

 
Copy / Paste special options 
To use Special paste options (such as Values only, No 
formulas, skip blank cells or transpose data) first copy 
data range, then press Ctrl+Alt+V to display the Paste 
Special dialog box. (Select Transpose option to change 
data from row to columns orientation and vise versa.) 
 
 

http://tinyurl.com/h6dwkla
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Tips for Managing Your Data using Excel 
 
 

Best practices  
Use in conjunction with a "Data Dictionary"  
Keep track of changes made to your worksheet 
Back up data periodically or before any major change 
Use descriptive filenames 
 
Data entry guidelines: 

 Place variable names in first row  
 Use unique identifier per entity 
 Format columns to match variable type (date, 

numeric, text, etc.) 
 Enter string variables in a consistent case 
 Do not leave any blank rows in the date range  

 
Export Data 

 Save each sheet as separate file 
 Get rid of formulas – Use Copy > Paste special > 

Values only 
 Save as csv format; Encode UTF-8 character set 

 
See “How to save CSV file as UTF-8 in Microsoft Excel?” 
https://www.xadapter.com/how-to-save-csv-excel-file-as-utf-8-
encoded/#save-csv-microsoft-excel (http://tinyurl.com/ycfg9rae).  

 
Sources: 
Elliott, A C. (2006). Preparing data for analysis using Microsoft Excel. 
Journal of investigative medicine, 54(06), 334-341. 
 
Hook, Les A., et al. 2010. Best Practices for Preparing Environmental 
Data Sets to Share and Archive. Oak Ridge National Laboratory 
Distributed Active Archive Center, Oak Ridge, Tennessee, U.S.A. 
doi:10.3334/ORNLDAAC/BestPractices-2010 
(http://daac.ornl.gov/PI/BestPractices-2010.pdf) 

_________ 

Advanced filtering 
Select any cell in header row. Then go to menu: Home > 
Editing > Sort & Filters > Filter (Control + Shift + L).  
 
In addition to key word search and a complete listing of 
values found in each column, Excel provides special filter 
options based on field type. For example, Date filters will 
provide options such as before or after a date, by period 
such as month, quarter, year, etc.; Number filters options 
include Top Ten values or above/below average. 
 
Data Lists 
Use Excel Data Lists for easy data entry. To apply, go to 
menu: Home> Styles > Format as table (press Alt+HT). 
Click Yes, then select formatting style from gallery 
thumbnails.  

Excel will automatically:  
 Apply Filters to the data range.  
 If add a column with a new formula, will 

automatically copied down for all rows.  
 Use tab key to automatically go to a new row for 

quick data entry.  
 
To convert table back to normal cell range, first click on 
any cell in data table, then go to menu: Table Tools > 
Design Tab> Tools >Convert to Range button. Then click 
Yes to convert. To remove residual formatting, select data 
range, Home > Font > Fill button > No Fill.  
 

Get External Data 
Import Text Files 
Text or Flat files contain only data, no formulas or 
formatting. To import, go to menu: Data > Get External 
Data > From Text. Double-click the text file that you wish 
to import in the Import Text File dialogue box. Then click 
Import. This will pull up the Text Import Wizard ... 
 
Text to columns 
To split data into multiple columns either by character 
(comma, tab, space, etc.) or by fixed width.  
  
Go to menu: Data > Data Tools >Text to Columns. This 
starts the Convert Text to Columns Wizard. In step 1: 
Click Delimited or select Fixed Width option; In Step 2) 
Enter character to split text or manually parse text; In Step 
3) Optional. Here can select destination cell or exclude 
columns to split. Also configure field types (text, dates, 
etc.) Tip: Use Data Preview Window to verify results. 
 
For screen shots see “Split text into different columns with the Convert 
Text to Columns Wizard” https://support.office.com/en-us/article/Split-
text-into-different-columns-with-the-Convert-Text-to-Columns-Wizard-
30B14928-5550-41F5-97CA-7A3E9C363ED7 
(https://tinyurl.com/y6vgd6nx). 
 
Web Query 
To import data from a website into your worksheet, go to 
menu: Data tab> external queries > from web> paste 
URL> Press GO. In the Web Query dialog box, select 
table from webpage to import by clicking on yellow 
arrow. When this arrow turns blue, click Import. 
 
Datasets for Teaching and Learning. For list of 
freely available datasets, see 
http://libguides.rice.edu/data_resources/samples

 

  

http://tinyurl.com/ycfg9rae
http://daac.ornl.gov/PI/BestPractices-2010.pdf
https://tinyurl.com/y6vgd6nx
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Advanced Functions 
 

VLOOKUP 
To pull specific data from a separate table. When using a VLOOKUP, you define a value (lookup_value) and the formula 
looks for it in the leftmost column of a table (table_array). 
 

SYNTAX: VLOOKUP( lookup_value, table_array, col_index_num, range_lookup) 
 

lookup_value WHAT -- The value that you want to search for. 
table_array WHERE -- The range of data that is to be searched for the lookup_value. 

Note: The Vlookup function searches in the left-most column of this array. 
col_index_num WHICH COLUMN -- the column number of the supplied table_array, that you want to return a value 

from. 
range_lookup OPTIONAL. For exact match use FALSE, for first closest match use TRUE. If left blank, excel 

defaults to TRUE. 
 
CRITERIA BASED CALCULATIONS 
Use functions SUMIF/S, AVERAGEIF/S and COUNTIF/S to return a sum, average or count of values that meet some 
specified criteria. NOTE: Can use the wildcard characters—the question mark (?) and asterisk (*)—as part of 
the criteria argument. A question mark matches any single character; an asterisk matches any sequence of characters. If you 
want to find an actual question mark or asterisk, type a tilde (~) preceding the character. 
 
APPEND AND SEARCH FUNCTIONS 
CONCATENATE–To join two or more values into one string. Joined values can be text, numbers or cell references. 
SEARCH– returns the location of a substring within a cell. 
FIND–Same as SEARCH but case sensitive. 
 
DATA MANIPULATION FUNCTIONS 
CLEAN–Removes all nonprintable characters from text (e.g. hard line breaks, Tabs, null characters) 
TRIM– Removes extra white spaces from text sting, leaving one space between words 
TEXT–Formats a number and converts it to text (such converting long date values) 
UPPER, LOWER, PROPER–Convert case 
LEFT, RIGHT–Extract text strings 
 
For specific examples and syntax see: Excel functions (by category) at https://support.office.com/en-us/article/Excel-
functions-by-category-5f91f4e9-7b42-46d2-9bd1-63f26a86c0eb (http://tinyurl.com/zvpkuub).  
 

Conditional formatting 
Apply cell formatting to visualize trends, spot unusual values or provide instant analysis.  
 
Steps: 

1) Select range to apply formatting  
2) Go to menu: Home > Styles > Conditional Formatting 
3) Select a rule or formatting style from many available options 

a. Basic rules : highlight cells based on criteria such as greater than/less, top/bottom values, text, dates, and 
even for duplicate values. 

b. Graphical forms :  defined styles—or presets. Data Bars, Color Scales and Icon Sets show a range between 
the highest, lowest, and mid-range values. Automatically formatted between three to five levels. 

c. Other options : Create custom rules or edit rules (manage) and clear conditional formatting 
 
See more at: Excel 2016: Conditional Formatting. https://www.gcflearnfree.org/excel2016/conditional-formatting/1/ 
(http://tinyurl.com/yd929vhu).  

http://tinyurl.com/zvpkuub
http://tinyurl.com/yd929vhu
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Advanced Pivot Tables Tips 
 
Need a refresher on basic Pivot Tables? See “Create a PivotTable to analyze worksheet data” at 
https://support.office.com/en-us/article/Create-a-PivotTable-to-analyze-worksheet-data-a9a84538-bfe9-40a9-a8e9-
f99134456576?ui=en-US&rs=en-US&ad=US (https://tinyurl.com/y7sew8j3) 
 
Recommended PivotTables 
Provides suggested Pivot Tables configurations. This feature gives a quick starting point which you can continue to adjust. 
 

Steps: 
1) Place cell pointer in any cell of data list 
2) Go to Insert tab > Tables > Recommended button 
3) Select one of the thumbnails in the preview window 

 
 

Tabular View 
Go to menu: Pivot Table Tools> Design Reports Layout > Show in tabular form. Instead of the default view provides a more 
spreadsheet style layout, which is easier to apply formulas or to copy and paste data. 
 
Calculated Fields 
Used to insert custom formulas to your report. Calculate fields are computed by a formula using existing numeric fields 
found in the data source. 
 
Steps: 

1) Click on any cell in the Pivot Table  
2) Go to menu: Pivot Table Tools > Analyze > Calculations > Field, items & sets Button 
3) Selection Insert Calculated field  
4) In dialog box, Enter Name for new field  
5) In formula box, delete zero after equal sign and click on field to base to use in formula and then enter formula using 

any arithmetic operator (+, - , * or / ). For example: Taxes = Revenue *.15. 
6) Press OK to insert calculated field 

Note: The new Calculated field will appear in Task Pane. Calculated fields can be toggled on and off like any other 
field from the task panel. 

 
Changing a calculation function  
Use alternative calculation for default value. For example: Add percentage instead of sum for a field (e.g. revenues).  

 Add 2nd copy of field to Values section of the Task Pane. 
 Right click on cell in pivot table report 
 Select Show Values as > % of Grand Total 

 
Other tips: 

 Remember to “Refresh” pivot table when adding content to data source (Right click over table and select “refresh” 
or Go to Pivot Table Options > Change data source and update range manually).  

 To view details that make up a subtotal double click on cell. This creates a new table showing details (i.e. complete 
rows) making up the subtotal. 

 Change default header names: 
o Double Click on label and type in updated text  
o Turn off field headers (Pivot Table > Options > Show > Field Headers) 
o Switch report layout (Pivot Table > Design > select Outline or Tabular layout. 

 Retain any formatting by using Value Field Settings (otherwise formatting may disappear upon refresh or change) 
 
 
 

https://tinyurl.com/y7sew8j3

